Technical Support

This website is supported through a range of browsers. These are:

  • Internet Explorer (IE) 11
  • Microsoft Edge 86 and above
  • Chrome 86 and above
  • Firefox 78 and above
  • Safari 14 and above

Get Involved is supported by Windows 7 and upwards and MacOS 10.6 and upwards. 

  • Should you experience any difficulty submitting your survey, please try the following:
  • Check what browser you are using, by clicking this link (External Site)- https://www.whatismybrowser.com/.

If your browser is not on the list above or you are on an older version of the browsers listed above, we highly recommend you upgrade to the latest. Not only will you have a better Get Involved experience, you'll have a much better (and safer!) general web experience, too.

If upgrading your browser does not help or you are running into other issues, please email us at support@engagementhq.com (External link)